fbpx

Foros

Avisos
Vaciar todo

Sensores sharp de distancia.

Página 1 / 3

beamspot
Respuestas: 1132
Registrado
Topic starter
(@beamspot)
Ardero noble
Registrado: hace 15 años

Hola:

Me estoy peleando con los sensores Sharp de medida de distancia por infrarrojos y triangulación (GP2Y0A21 y GP2Y0A41, de 10 a 80 cm uno y de 4 a 30cm el otro). De momento sólo es una idea, pero busco información, y soy tan inútil que no la encuentro.

En mi escaso sentido común, me dice que la distancia se mide entre dos puntos. Uno de ellos es obivamente el que quiero medir, pero el segundo, el punto de referencia o partida... no lo encuentro.

Dicho más claro: la distancia que mide el sensor es respecto del plano en que se atornilla el mismo o es respecto del plano de la PCB que hay dentro (a 3 mm del plano de atornillado)? ¿Es el plano de salida de las ópticas? ¿Es el plano de la superfície del sensor?

Puede que no venga mucho de aquí para según que cosas, pero si quiero medir una distancia de 4 o 5 cm, los 13mm de diferencia entre el plano de las lentes y el plano de atornillado me incluyen un error de 26% (1.3 sobre 5 cm...). ¿Alguien con experiencia en estos sensores?

De momento no tengo ninguno a mano, pero para la semana que viene espero tener la respuesta. Si nadie me contesta, ya la pondré yo.

Saludos y buen finde!

Responder
10 respuestas
sphinx
Respuestas: 651
Socio Socio
(@sphinx)
Ardero honorable
Registrado: hace 14 años

Hola beamspot,

Yo me estuve peleando un poco con ellos.
Este artículo siempre me pareció bastante bueno. Además te enlaza con un par de conceptos que te van a ayudar y que son bastante importantes, como por ejemplo el ruido que vas a recibir en la patilla del micro cuando leas el valor analógico del sensor y como solucionarlo. Esto está en la parte inferior del artículo (Sharp IR Noise). Parece una tontería pero es bastante chungo si no le acoplas el condesador//resistencia adecuados para paliar este efecto que te puede volver loco.

Saludos,
Sphinx.

Responder
dragonet80
Respuestas: 1328
Socio
(@dragonet80)
Ardero noble
Registrado: hace 15 años

Aqui hay unos comentarios muy interesantes:
http://www.societyofrobots.com/robotforum/index.php?topic=2712.30 " onclick="window.open(this.href);return false;

Si se pone a masa la carcasa ¿plastica! del sensor se elimanan bastante los ruidos...
No se me habria ocurrido nunca.

Responder
beamspot
Respuestas: 1132
Registrado
Topic starter
(@beamspot)
Ardero noble
Registrado: hace 15 años

Gracias por la info.

Como otras veces, buscando una información, no sólo no la encuentro, si no que me entero de cosas más relevantes.

Al final resulta que en casa tenía tirado por ahí un GP2d120, que no es el mismo, pero al menos lo he puesto a probar, y, efectivamente, ahora ya sé donde conseguir un chisme que me genere ruido eléctrico. Alimentado con una fuente de laboratorio y con un osciloscopio, da una seña bastante fea.

Voy a hacer algunas pruebas más cuando pueda, y sigo informando.

Responder
beamspot
Respuestas: 1132
Registrado
Topic starter
(@beamspot)
Ardero noble
Registrado: hace 15 años

Bueno, he hecho algunas pruebas, y al parecer el chisme pega unos picos de consumo bastante bestias, motivo por el cual hace tanto ruido eléctrico.

Al ponerlo en marcha, la fuente estaba a 5V 50mA, y se amorraba, pero con un consumo de 20-25 mA. Con un cerámico 0603 de 100nF, los picos desaparecían a la salida, pero seguía haciendo el perro. Luego he subido el límite a 200mA y funcionaba mejor, pero la salida de la fuente no reportaba los 5V fijos habituales. Al final, limitando a 0.5A, con un condensador de desacoplo de 47uF 1210 16V en los pines directos del sensor, funciona de maravilla, sin ruido. Y sigue reportanto 20-25mA de consumo... Raro.

Parece lógico que el problema sea el consumo del led emisor, que echará unos pulsos tremendos de corriente. De ahí el ruido y los desacoplos.

Seguiré informando.

Responder
Página 1 / 3
Compartir: